Packet tracer

Hemos configurado una red con Rip, rutas estaticas, salida a internet, ospf, nat, vlans, ssh, vtp y switchs de capa 3.

Para crear el vlsm hemos escogido una id de red 172.31.0.0/16.

El nombre de cada Vlan:

  • vlan 10 Finanzas.
  • vlan 20 Recursos humanos.
  • vlan 30 Profesores.
  • vlan 40 Mantenimiento.
  • vlan 50 Informatica.
  • vlan 99 nativa.

Configuración

Lo primero que hay que realizar es el diseño de la red con los dispositivos y el cableado corespondiente.

Una vez realizado el diseño de la red, comenzamos a configurar la parte de internet.

Lo primero es configurar las interfaces:

  • enable
  • conf termi
  • interface gigabitEthrnet o (el cable al que este conectado)
  • ip address (ip + mask)
  • no shutdown
  • exit

Ya configurada todas las interfaces, verificamos que esta todo correcto, donde tenemos los dispositivos conectados con cable serial configuramos la zona del clock rate.

  • enable
  • configure terminal
  • interface serial (la que tiene el clock rate)
  • clock rate 56000

Configuracion Rutas estaticas

Hemos elegido los router 10 y 11 para estaticas.

comandos

  • enable
  • configure terminal
  • ip route ip destino + mascara +ip del siguiente salto

Configuración Rip

Hemos elegido los router 2, 5, 6, 7, 9 para Rip

Comandos:

  • enable
  • conf termi
  • router rip
  • version 2
  • network (ip de red que esta conectado)

El router que esta configurado rip y rutas estaticas, que es el que esta entre medias, es el que va compartir con los demás router lo que sabe, y para ello se pone el siguiente comando

redistribute static

Una vez echo todo esto y verificamos que todo es correcto pasaremos. Pasamos a configurar el lado LAN.

Comenzamos con OSPF

Esto se configura en todos los router de la LAN.

Comandos:

  • enable
  • conf termi
  • router ospf 1
  • network (Subred + wild card + area 0)

hemos elegido el router 8 para que sea el DR por que es el que menos trafico va ha tener, el BDR es el router 3 y el ISP es el que esta conectado entre la LAN y internet.

Configuracion del DR BDR y ISP

  • Ip ospf priority 255 (DR)
  • ip ospf priority 0 a 255 (BDR)
  • ip ospf priority 0 (ISP)

Router ISP

tenemos que configurar NAT para que internet no sepa llegar a la LAN

Despues de eso configuramos nat con la acl

  • enable
  • conf termi
  • (elegimos que interfaz queremos que esta dentro y cual va ha salir fuera)
  • interface gigabyteEthernet 0/0
  • ip nat inside
  • interface gigabyteEthernet 0/1
  • ip nat outsite
  • exit
  • access-list 1 permit 192.168.0.1 0.0.0.255
  • ip inside source-list 1 gigabyteEthernet 0/1 overload

Configuración SSH

para hacer ssh tenemos que escoger un switch en nuestro caso lo vamos ha configurar el el servidor vtp. Los comandos son los siguientes:

  • enable
  • conf t
  • interface vlan 99
  • ip address (siempre que no sea la misma que la gateway)
  • no shutdown
  • ip dafault-gateway 172.31.16.97 255.255.255.224
  • hostname Sw-server
  • ip domain name maristak.com
  • crypto key generate rsa(le damos 1024 bits)
  • line vty 0 15
  • login
  • password cisco
  • exit
  • show ip ssh (comprobamos si esta activado ssh)

Enlace permanente a este artículo: http://asir.maristak.com/packet-tracer-3/

Proyecto Red

Primero debemos medir y saber las dimensiones que debe tener nuestra Red, A raíz de eso preparamos un VLSM que nos ayudara a la hora de darle direcciones a los dispositivos y que VLAN-s crear también teniendo en cuenta la parte de expandirse en un futuro.

Antes de crear el VLSM y teniendo en cuenta los rangos que tenemos creamos el diseño de la red,como podéis observar en la imagen este seria nuestro diseño.

DISEÑO DE LA RED

Dentro de nuestra red hemos metido 16 switch-es de capa 2,1 switch de capa 3 y un servidor vtp en la parte superior para luego poder configurar con mas facilidad y comodidad las VLAN-s. Enesta imagen podemos apreciar que la red se divide en 2 partes a la derecha del recuadro verde es la parte de internet y la parte izquierda la LAN.

Después de poner los dispositivos lo primero que hicimos fue conectar todo cableandolos entre si, en la parte del media podéis observar que esta la conexión LAN y al final la salida hacia a Internet, el router que esta en medio con el color verde seria el limite entre OSPF y Internet donde configuramos la NAT.

Para configurar este router utilizamos el siguiente comando: Router(config)#access-list 1 permit [dirección de origen][mascara].

Y para la configuración de ospf hemos seguido este este comando:

Lo primero que haremos después de cablear sera apagar todas las interfaces que no vallamos a usar después de hacer eso iremos a poner vlans a los switch correspondientes y para facilitar el trabajo como hemos dicho anteriormente haremos un servidor y dentro guardaremos las vlans para luego distribuirlo mas fácilmente con solo tres comandos.

Con los datos que tenemos nosotros gracias a la ONG hemos creado estas VLAN-s 10,20,30,50,60,70,99, la ultima que he puesto actuara como VLAN nativa y de administración.

Para poder compartir las VLAN-s lo mas importante es tener conexión entre switch-es,con eso podremos compartir la información,primero hay que escojer por que interfaz se esta conectando con el otro switch y darle conexión, asi con todas la interfaces que uses

Teniendo en cuenta que tenemos el servidor configurado y con conexión cuando al siguiente switch le pongas los siguientes comando automáticamente estarán dentro del mismo dominio y se compartirán las VLAN-s.

Sabiendo que tenemos conexión entre switch-es, todos están en el mismo dominio y que las VLAN-s están compartidas procederemos a meter a los ordenadores en las VLAN-s y darle dirección ip y gateways.

Para ello, entraremos a configurar el router y encenderemos el puerto que está conectado al Switch, dentro del modo de configuración, escribiremos el comando para entrar a la interfaz del puerto, pero en este caso, le añadimos el «.» y a continuación del punto la ID de la VLAN que queramos añadir. Después escoger la interfaz para poder poner mas de una dirección ip tenemos que poner el comando «encapsulation dot1Q <ID VLAN>» y después al poner la nativa tendríamos que poner este comando «encapsulation dot1Q <ID VLAN> native « .

Despues de haber configurado VTP y todos los puertos que vamos a utilizar, el siguiente paso es utilizar una forma de enrutar entre Vlans, el metodo que hemos utilizado es ROAS (Router On A Stick), este método consiste en crear subinterfaces lógicas en el router acorde a la cantidad de VLAN.

Lo siguiente que haremos es ponerle interface virtual a los switches para poder activar el protocolo de SSH y le pondremos la puerta de enlace que seria la primera ip de la nativa

El siguiente paso seria meter SSH para que pueda haber conexión remota.

Para empezar, añadiremos contraseña a la terminal ,al modo acceso y a las lineas VTY y de esta manera protegeremos el Switch. Una vez que hemos realizado esto, insertaremos el comando «crypto key generate rsa», nos pedirá que introduzcamos un número, es recomendable que ese número que introducimos sea mayor a 1024 para mayor seguridad.

Por ultimo pondremos una contraseña a la linea vty para ello necesitaremos escribir <line vty 0-15> después <password> y la contraseña que queremos, y para que se confirme <login>. Por ultimo para proteger el modo telnet <enable secret> y la contraseña, en este caso class, si queremos que las contraseñas se encripten todas las contraseñas <service password-encruption>.

Después de haber configurado la mayor parte de nuestra red procederemos a la configuración de switch de capa 3. La Capa 3 se encarga del enrutamiento de paquetes mediante el direccionamiento lógico y el control de subredes. Un router es el dispositivo de red más común dentro de la Capa 3. Éste se encarga de enrutar los paquetes a su respectiva dirección IP (Internet Protocol) de destino. En la Capa 3, se comprueban las direcciones IP de origen y destino de cada paquete en la tabla correspondiente de enrutamiento IP, y se decide el salto siguiente en la ruta del paquete (a un router o a un switch). Si no se encuentra ninguna IP de destino en la tabla, se soltará el paquete a menos de que disponga de un router predeterminado.

Las VLAN-s no se crean como en un switch normal entonces

Para poder configurar el modo trunk en las interfaces tenemos que ponerle <switchport trunk encapsulation dot1q> porque una interfaz cuya encapsulación troncal es «Auto» no se puede configurar en modo «troncal» y al poner el comando se cambia a

Tenemos que poner todas las puertas de enlace de las vlans que vayan a pasar por el switch.

Para poder configurar la interfaz para el enrutador predeterminado, utilizaremos es siguinete comando,<La interfaz>,<no switchport>, <La direccion que le quieras poner> El comando no switchport hace que la interfaz Capa 3 sea capaz de poder poner enrutamiento en el switch.

Para poder ver nuestro reto ciclad aquí:

Enlace permanente a este artículo: http://asir.maristak.com/proyecto-red/

OSPF (Open Shortest Path First)

Es un protocolo de direccionamiento de tipo enlace-estado, desarrollado para las redes IP y basado en el algoritmo de primera vía más corta (SPF). OSPF es un protocolo de pasarela interior (IGP).

Las ventajas principales de OSPF son las siguientes:

  • En comparación con los protocolos de direccionamiento de distancia-vector como el protocolo de información de direccionamiento (RIP), OSPF es más adecuado para servir entre redes heterogéneas de gran tamaño. OSPF puede recalcular las rutas en muy poco tiempo cuando cambia la topología de la red.
  • Puede dividir un sistema autónomo (AS) en áreas y mantenerlas separadas para disminuir el tráfico de direccionamiento de OSPF y el tamaño de la base de datos de enlace-estado de cada área.
  • Proporciona un direccionamiento multivía de coste equivalente. Se pueden añadir rutas duplicadas a la pila TCP utilizando saltos siguientes distintos.
  • Comandos:
  • enable
  • configure terminal
  • router ospf 1
  • network (Subred) + (wild card) + (área 0)

Enlace permanente a este artículo: http://asir.maristak.com/ospf-open-shortest-path-first/