Grupo 4

Introducción

En este reto nos encontramos con una empresa que nos pide crear topologías de red para  dos oficinas separadas por 3KM.

En la oficina 1 nos encontramos 5 subredes conectadas a través de routers. Para empezar observamos un cable cruzado entre routers. En esta primera oficina nos encontramos con un departamento que contiene 10 empleados y 4 impresoras , otro en el que hay 30 portátiles , y por último otro en el que encontramos  50 torres y una sala de servidores con 5 servidores.  En esta oficina el enrutamiento se hará mediante rutas estáticas y RIP.

En la oficina 2 en vez de usar routers han preferido abaratar los costes y nos han pedido que utilicemos VLANs. Hay cuatro switches conectados de manera troncal. En esta oficina el enrutamiento se hará mediante OSPF. Estas serían las VLANs que están en uso:

  • Primera VLAN: 15 empleados
  • Segunda VLAN: 40 empleados
  • Tercera VLAN: 70 empleados
  • Cuarta VLAN: 130 empleados
  • Sala de Servidores: 4 Servidores

La primera y la segunda oficina están conectadas mediante un enlace WAN. Tiene que haber conectividad de cualquier punto de la red a cualquier otro. Esta empresa solo puede tener una salida a internet.

En este reto nos encontramos con una empresa que nos pide crear topologías de red para  dos oficinas separadas por 3KM.

En la oficina 1 nos encontramos 5 subredes conectadas a través de routers. Para empezar observamos un cable cruzado entre routers. En esta primera oficina nos encontramos con un departamento que contiene 10 empleados y 4 impresoras , otro en el que hay 30 portátiles , y por último otro en el que encontramos  50 torres y una sala de servidores con 5 servidores.  En esta oficina el enrutamiento se hará mediante rutas estáticas y RIP.

En la oficina 2 en vez de usar routers han preferido abaratar los costes y nos han pedido que utilicemos VLANs. Hay cuatro switches conectados de manera troncal. En esta oficina el enrutamiento se hará mediante OSPF.

Estas serían las VLANs que están en uso:

  • Primera VLAN: 15 empleados
  • Segunda VLAN: 40 empleados
  • Tercera VLAN: 70 empleados
  • Cuarta VLAN: 130 empleados
  • Sala de Servidores: 4  Servidores

La primera y la segunda oficina están conectadas mediante un enlace WAN. Tiene que haber conectividad de cualquier punto de la red a cualquier otro. Esta empresa solo puede tener una salida a internet.

¿Qué es DMZ?

 

Dicho todo esto tendremos que explicar el concepto de DMZ,( ya que nos sería muy útil para proteger nuestros servidores), en seguridad informática  una zona desmilitarizada(conocida también como DMZ) o red perimetral es una zona segura que se ubica entre la red interna de una organización y una red externa, generalmente en Internet. El objetivo de una DMZ es que las conexiones desde la red interna y la externa a la DMZ estén permitidas, mientras que en general las conexiones desde la DMZ sólo se permitan a la red externa. Los equipos (hosts) en la DMZ no pueden conectar con la red interna.

VLSM de las oficinas

 

Este ,en concreto, es el VLSM que hemos utilizado para crear la topología de la oficina 1 de la empresa:

 

vlsm1

Hemos utilizado este VLSM  porque tenemos 50 torres en el departamento 3, 30 portátiles en el departamento 2 , 10 empleados y 4 impresoras en el departamento 1 , una sala de servidores constituida por 4 servidores y para terminar un cable cruzado entre routers que equivale a 2 nodos.

Este es el VLSM que hemos utilizado concretamente para crear la topología de la oficina 2:

vlsm2

Hemos utilizado este VLSM concretamente porque en la primera VLAN tenemos que meter 15 empleados, en la segunda 40, en la tercera 70, en la cuarta 130 y en la última que sería una sala de servidores encontraremos 4 servidores. Como podemos observar hemos utilizado  el tamaño fijándonos en el número de empleados  que tenemos en cada VLAN, y hemos dado algo de margen de crecimiento.

Como podemos observar a la última subred hemos decidido darle un tamaño de 2, para que así pueda albergar el ISP,  para que de esta manera podamos salir a Internet.

VLANs y VTP

Como hemos explicado antes la oficina 2 la hemos configurado utilizando VLANs, dicho esto para el correcto funcionamiento de las VLANs hemos tenido que configurar el VTP (VLAN Trunking Protocol). Este protocolo, es un protocolo de mensajes de nivel 2 usado para configurar y administrar VLANs en equipos Cisco. Permite centralizar y simplificar la administración en un dominio de VLANs, pudiendo crear, borrar y renombrar las mismas.

El protocolo VTP opera en 3 modos:

  • Modo Servidor: Es el modo por defecto. Desde el se pueden crear, eliminar o modificar VLAns. Su cometido es anunciar su configuración al resto de switches del          mismo dominio VTP y sincronizar con la de otros servidores, basándose  en los    mensajes VTP recibidos a través de sus enlaces troncales.
  • Modo Cliente: En este modo no se pueden crear, eliminar o modificar VLANs , tan solo sincronizar esta información basándose en los mensajes VTP recibidos de servidores en             el propio dominio. Un cliente VTP sólo guarda la información de la VLAN para el             dominio completo mientras el switch está activado. Un reinicio del switch borra la i            información de la VLAN.
  • Modo Transparente: Desde este modo tampoco se pueden crear, eliminar o modificar VLANs que afecten a los demás switches. La información VLAN en los switches que             trabajen en este modo solo se puede modificar localmente. No procesa las             actualizaciones VTP recibidas, tan solo las reenvía a los switches del mismo dominio.

 

 

 

Topología

Esta es la topología que hemos utilizado

TOPOLOGIA

Las zonas marcadas con colores indican los métodos de enrutamiento que hemos utilizado en la topología: la sala de servidores de la primera oficina (en rojo) está configurada con rutas estáticas y el resto de oficinas utiliza RIP (en amarillo). Los routers que interconectan las dos oficinas, junto con ISP, utilizan OSPF como método de enrutamiento, mientras que la segunda oficina funciona con VLANs.

 

Como podemos observar en la imagen en el lado de las VLANs  hemos utilizado dos topologías en anillo, unidas por un enlace troncal, esto lo que nos da es una mayor velocidad en la red, porque de esta manera los paquetes no tienen que recorrer tanta distancia para llegar de un switch a otro.

Una red en anillo es una topología de red en la que cada estación tiene una única conexión de entrada y otra de salida. Cada estación tiene un receptor y un transmisor que hace la función de traductor, pasando la señal a la siguiente estación. En este tipo de red la comunicación se da por el paso de un «token» o testigo, que se puede comparar a un cartero que pasa recogiendo y entregando paquetes de información, de esta manera se evitan pérdidas de información debidas a colisiones.

Ventajas esta topología:

  • El sistema provee un acceso equitativo para todas las computadoras.
  • El rendimiento no decae cuando muchos usuarios utilizan la red.
  • Arquitectura muy sólida.

Desventajas:

  • Longitudes de canales
  • El canal usualmente se degradará a medida que la red crece.
  • Difícil de diagnosticar y reparar los problemas.
  • Si se encuentra enviando un archivo podrá ser visto por las estaciones intermedias antes de alcanzar la estación de destino.

 

Configuración

 

Pasaremos a revisar la configuración que tenemos en cada router y en los switches de la VLAN.

La VLAN tiene la dirección IP 172.30.0.0 . Es una IP de clase B ya que el tamaño de la red nos obligaría a utilizar 2 direcciones IP de clase C para alojar nuestros host. La gran cantidad de dispositivos finales también es la razón por la que hay 14 switches, con un enlace troncal en mitad del anillo para agilizar el tráfico.

interface FastEthernet0/1

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/2

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/3

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/4

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/5

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/6

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/7

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/8

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/9

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/10

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/11

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/12

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/13

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/14

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/15

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/16

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/17

switchport access vlan 50

switchport mode access

!

interface FastEthernet0/18

switchport access vlan 50

switchport mode access

!

interface FastEthernet0/19

switchport access vlan 50

switchport mode access

!

interface FastEthernet0/20

switchport access vlan 50

switchport mode access

!

interface FastEthernet0/21

switchport access vlan 50

switchport mode access

!

interface FastEthernet0/22

switchport mode access

shutdown

!

interface FastEthernet0/23

switchport mode access

shutdown

!

interface FastEthernet0/24

switchport mode access

shutdown

!

Como vemos, los puertos fastethernet del 1 al 6 son enlaces troncales para interconectar los switches, y el resto de interfaces están configuradas en modo acceso para que los dispositivos finales puedan conectarse a ellos. Su IP para configurar mediante acceso remoto es  172.30.99.5 255.255.255.224 y su gateway por defecto es 172.30.99.1. Al configurar este switch en modo servidor, hemos creado en él el dominio MARISTAK con la contraseña ASIR1 para que los demás switches se unan al mismo, y hemos creado las VLAN en él, para que se propaguen entre los switches en modo cliente.
VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/22, Fa0/23, Fa0/24
10 RRHH active
20 Informatica active
30 DG active Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16
40 Finanzas active
50 Servers active Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21
99 Admon active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

Estas son las vlan que hemos creado. En la imagen también podemos ver que la sala de servidores está gestionada mediante este switch, así como parte del departamento de diseño gráfico. Todos los switches de la VLAN tienen una IP configurada para posibilitar la gestión remota.

El router que da conectividad a la VLAN tiene configuradas las subinterfaces lógicas correspondientes a las VLAN, y además es el router que utilizamos para interconectar ésta oficina con la otra. Además, conectado a este router está también el router ISP, que nos dará conectividad a internet. Estos 3 routers que acabamos de mencionar enrutan mediante OSPF.

interface FastEthernet0/0

ip address 172.30.1.241 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.10

encapsulation dot1Q 10

ip address 172.30.1.193 255.255.255.224

!

interface FastEthernet0/1.20

encapsulation dot1Q 20

ip address 172.30.1.129 255.255.255.192

!

interface FastEthernet0/1.30

encapsulation dot1Q 30

ip address 172.30.1.1 255.255.255.128

!

interface FastEthernet0/1.40

encapsulation dot1Q 40

ip address 172.30.0.1 255.255.255.0

!

interface FastEthernet0/1.50

encapsulation dot1Q 50

ip address 172.30.1.225 255.255.255.240

!

interface FastEthernet0/1.99

encapsulation dot1Q 99 native

ip address 172.30.99.1 255.255.255.224

!

interface Serial0/0/0

ip address 192.168.3.2 255.255.255.252

clock rate 2000000

!

interface Serial0/0/1

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 172.30.1.192 0.0.0.31 area 0

network 172.30.1.128 0.0.0.63 area 0

network 172.30.1.0 0.0.0.127 area 0

network 172.30.0.0 0.0.0.255 area 0

network 172.30.1.224 0.0.0.15 area 0

network 192.168.3.0 0.0.0.3 area 0

network 172.30.1.240 0.0.0.3 area 0

default-information originate

!

ip classless

ip route 192.168.1.64 255.255.255.192 192.168.3.1

ip route 192.168.1.0 255.255.255.192 192.168.3.1

ip route 192.168.1.160 255.255.255.248 192.168.3.1

 

En la primera oficina, cuya IP es 192.168.1.0 tenemos routers configurados exclusivamente con rutas estáticas, y routers que utilizan RIP, además del router que interconecta las oficinas, que además de esto tiene OSPF. El router configurado con rutas estáticas da conectividad al servidor, ya que las rutas estáticas son consideradas más fiables.

ip classless

ip route 192.168.1.128 255.255.255.224 192.168.1.177

ip route 192.168.3.0 255.255.255.252 192.168.1.177

ip route 192.168.1.64 255.255.255.192 192.168.1.177

ip route 192.168.1.0 255.255.255.192 192.168.1.177

ip route 172.30.1.192 255.255.255.224 192.168.1.177

ip route 172.30.1.128 255.255.255.192 192.168.1.177

ip route 172.30.1.0 255.255.255.128 192.168.1.177

ip route 172.30.0.0 255.255.255.0 192.168.1.177

ip route 172.30.1.224 255.255.255.240 192.168.1.177

ip route 0.0.0.0 0.0.0.0 192.168.1.177

!

El resto de la oficina utiliza RIP para enrutar.

interface FastEthernet0/0

ip address 192.168.1.66 255.255.255.192

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.192

duplex auto

speed auto

!

interface Vlan1

no ip address

shutdown

!

router rip

version 2

redistribute static

network 192.168.1.0

!

ip classless

ip route 172.30.1.192 255.255.255.224 192.168.1.65

ip route 172.30.1.128 255.255.255.192 192.168.1.65

ip route 172.30.1.0 255.255.255.128 192.168.1.65

ip route 172.30.0.0 255.255.255.0 192.168.1.65

ip route 172.30.1.224 255.255.255.240 192.168.1.65

ip route 0.0.0.0 0.0.0.0 192.168.1.65

!

Y como podemos comprobar el router que interconecta las oficinas tiene RIP y OSPF.

interface FastEthernet0/0

ip address 192.168.1.129 255.255.255.224

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.1.177 255.255.255.252

duplex auto

speed auto

!

interface Serial0/0/0

ip address 192.168.3.1 255.255.255.252

!

interface Serial0/0/1

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 192.168.1.176 0.0.0.3 area 0

network 192.168.3.0 0.0.0.3 area 0

network 192.168.1.128 0.0.0.31 area 0

default-information originate

!

router rip

version 2

redistribute static

network 192.168.1.0

!

ip classless

ip route 192.168.1.160 255.255.255.240 192.168.1.178

Par garantizar la conectividad entre las dos oficinas se han complementado los enrutamientos dinámicos con enrutamiento estático, ya que, de otra manera, no habría conectividad entre los dispositivos finales de la VLAN con los dispositivos de la primera red.

Además de esto, en la segunda oficina está el ISP. En este tenemos creadas las listas de acceso con ambas redes para que, mediante NAT, tengamos conectividad con internet. Además de esto, el ISP tiene configurado OSPF, por lo que hemos añadido una ruta estática por defecto que hemos propagado al resto de router que tienen OSPF. Además. este router también está complementado con rutas estáticas dado que mediante OSPF no recibía la información de ciertos routers, y de este modo, aunque dichos routers supiesen dirigir su tráfico a este router, él no podría devolver los paquetes, y por su ruta estática por defecto los devolvería a internet.

interface FastEthernet0/0

ip address 172.30.1.242 255.255.255.252

ip nat inside

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

ip address 88.88.88.88 255.0.0.0

ip nat outside

!

interface Serial0/0/1

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 172.30.1.240 0.0.0.3 area 0

network 88.0.0.0 0.255.255.255 area 0

default-information originate

!

ip nat inside source list 1 interface Serial0/0/0 overload

ip nat inside source list 2 interface Serial0/0/0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 88.88.88.89

ip route 192.168.1.160 255.255.255.240 172.30.1.241

ip route 192.168.1.64 255.255.255.192 172.30.1.241

ip route 192.168.1.0 255.255.255.192 172.30.1.241

!

ip flow-export version 9

!

!

access-list 1 permit 172.30.0.0 0.0.255.255

access-list 2 permit 192.168.1.0 0.0.0.255

Para finalizar, dado que la ruta estática por defecto se propaga mediante OSPF, la sala de servidores que hemos mencionado en la primera oficina, y los routers que no están directamente conectados al router configurado con OSPF no habrán recibido la ruta estática. Por ello, les hemos añadido la ruta estática por defecto manualmente.

 

 

 

 

 

 

 

 

 

Enlace permanente a este artículo: http://asir.maristak.com/grupo-4/